<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://talkofthesound.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/html5.js"></script>
	<![endif]-->
	<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="NEW ROCHELLE, NY &#8212; The New Rochelle Veterans Advisory Committee was joined by officials from American Legion Post 8 and the City of New Rochelle to celebrate&#8230;" />
<meta property="og:image" content="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?fit=1453%2C776&amp;ssl=1" />
<meta property="og:image:width" content="1453" />
<meta property="og:image:height" content="776" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes | Talk of the Sound" />
<meta property="og:description" content="NEW ROCHELLE, NY &#8212; The New Rochelle Veterans Advisory Committee was joined by officials from American Legion Post 8 and the City of New Rochelle to celebrate the installation of “Hometown Heroes”&#8230;" />
<meta property="og:url" content="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" />
<meta property="og:site_name" content="Talk of the Sound" />
<meta property="article:published_time" content="2020-07-27T17:29+00:00" />
<meta property="article:modified_time" content="2020-07-27T17:30+00:00" />
<meta property="og:updated_time" content="2020-07-27T17:30+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes | Talk of the Sound" />
<meta name="twitter:description" content="NEW ROCHELLE, NY &#8212; The New Rochelle Veterans Advisory Committee was joined by officials from American Legion Post 8 and the City of New Rochelle to celebrate the installation of “Hometown Heroes”&#8230;" />
<meta name="twitter:image" content="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?fit=1453%2C776&amp;ssl=1" />
<meta name="twitter:image:width" content="1453" />
<meta name="twitter:image:height" content="776" />
<link rel="canonical" href="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://talkofthesound.com/","name":"Trusted Provider of Local News in New Rochelle | Talk of the Sound"}},{"@type":"ListItem","position":2,"item":{"@id":"https://talkofthesound.com/category/front-page/","name":"Front-Page"}},{"@type":"ListItem","position":3,"item":{"@id":"https://talkofthesound.com/category/front-page/new-rochelle/","name":"New Rochelle"}},{"@type":"ListItem","position":4,"item":{"@id":"https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/","name":"New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 0.41ms meta | 0.62ms boot -->


	<!-- This site is optimized with the Yoast SEO plugin v14.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes | Talk of the Sound</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes | Talk of the Sound" />
	<meta property="og:description" content="NEW ROCHELLE, NY &#8212; The New Rochelle Veterans Advisory Committee was joined by officials from American Legion Post 8 and the City of New Rochelle to celebrate the installation of “Hometown Heroes” banners this morning at Faneuil Park. Veterans, banner sponsors and military moms were on hand along with Cpl. Guadalupe Mendoza. Afterwards, there was &hellip; Continue reading New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes" />
	<meta property="og:url" content="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" />
	<meta property="og:site_name" content="Talk of the Sound" />
	<meta property="article:published_time" content="2020-07-27T17:29:16+00:00" />
	<meta property="article:modified_time" content="2020-07-27T17:30:08+00:00" />
	<meta property="og:image" content="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?fit=1453%2C776&#038;ssl=1" />
	<meta property="og:image:width" content="1453" />
	<meta property="og:image:height" content="776" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://talkofthesound.com/#website","url":"https://talkofthesound.com/","name":"Talk of the Sound","description":"Considered the Source Since 2008","potentialAction":[{"@type":"SearchAction","target":"https://talkofthesound.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?fit=1453%2C776&ssl=1","width":1453,"height":776},{"@type":"WebPage","@id":"https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/#webpage","url":"https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/","name":"New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes | Talk of the Sound","isPartOf":{"@id":"https://talkofthesound.com/#website"},"primaryImageOfPage":{"@id":"https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/#primaryimage"},"datePublished":"2020-07-27T17:29:16+00:00","dateModified":"2020-07-27T17:30:08+00:00","author":{"@id":"https://talkofthesound.com/#/schema/person/4d8625cf85320f06ab9c6416bd96c6b7"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/"]}]},{"@type":["Person"],"@id":"https://talkofthesound.com/#/schema/person/4d8625cf85320f06ab9c6416bd96c6b7","name":"Robert Cox","image":{"@type":"ImageObject","@id":"https://talkofthesound.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=96&r=pg","caption":"Robert Cox"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.11.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.11.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-7445625-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-7445625-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentyfifteen-jetpack-css'  href='https://c0.wp.com/p/jetpack/8.7.1/modules/theme-tools/compat/twentyfifteen.css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/theme.min.css' media='all' />
<link rel='stylesheet' id='simple-sitemap-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/simple-sitemap/lib/assets/css/simple-sitemap.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dashicons.min.css' media='all' />
<link rel='stylesheet' id='cwp-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=1.3.3' media='all' />
<link rel='stylesheet' id='easy-social-sharing-general-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/css/easy-social-sharing.css?ver=1.3.3' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-Phone-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/intlTelInput.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-Country-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/countrySelect.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-admin-ui-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/rw-jquery-ui.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/richwebicons.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.2' media='all' />
<link rel='stylesheet' id='twentyfifteen-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/style.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/talkofthesound_wp/style.css?ver=1.39' media='all' />
<link rel='stylesheet' id='twentyfifteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%3A400italic%2C700italic%2C400%2C700%7CNoto+Serif%3A400italic%2C700italic%2C400%2C700%7CInconsolata%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.7.1/_inc/genericons/genericons/genericons.css' media='all' />
<link rel='stylesheet' id='twentyfifteen-block-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfifteen-ie-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/ie.css?ver=20170916' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentyfifteen-ie7-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/ie7.css?ver=20141210' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.7.1/css/jetpack.css' media='all' />
<script>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/talkofthesound.com","hash_tracking":"false"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.11.0'></script>
<script src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/ui/core.min.js'></script>
<script>
var object = {"ajaxurl":"https:\/\/talkofthesound.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/Rich-Web-Forms-Widget.js?ver=5.4.2'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/intlTelInput.min.js?ver=5.4.2'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/countrySelect.min.js?ver=5.4.2'></script>
<script type="application/json" id="wpp-json">
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/talkofthesound.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":57686,"token":"98bc8743ba","lang":0,"debug":0}
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.2'></script>
<link rel='https://api.w.org/' href='https://talkofthesound.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://talkofthesound.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://talkofthesound.com/wp-includes/wlwmanifest.xml" /> 
	<script type="text/javascript">
	    var ajaxurl = 'https://talkofthesound.com/wp-admin/admin-ajax.php';
	</script>

	<style type="text/css">
		.ajax-calendar{
			position:relative;
		}

		#ajax_ac_widget th {
		background: none repeat scroll 0 0 #2cb2bc;
		color: #FFFFFF;
		font-weight: normal;
		padding: 5px 1px;
		text-align: center;
		 font-size: 16px;
		}
		#ajax_ac_widget {
			padding: 5px;
		}
		
		#ajax_ac_widget td {
			border: 1px solid #CCCCCC;
			text-align: center;
		}
		
		#my-calendar a {
			background: none repeat scroll 0 0 #008000;
			color: #FFFFFF;
			display: block;
			padding: 6px 0;
			width: 100% !important;
		}
		#my-calendar{
			width:100%;
		}
		
		
		#my_calender span {
			display: block;
			padding: 6px 0;
			width: 100% !important;
		}
		
		#today a,#today span {
			   background: none repeat scroll 0 0 #2cb2bc !important;
			color: #FFFFFF;
		}
		#ajax_ac_widget #my_year {
			float: right;
		}
		.select_ca #my_month {
			float: left;
		}

	</style>
	<meta name="generator" content="Site Kit by Google 1.12.0" /><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>

<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-5602862681328597",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
					<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-7445625-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-7445625-1');
</script>

<meta name="google-site-verification" content="2pQqHhr3nJh9tZrey6jJUFybABtWyy34uFW1H_K6L9c" />

<script type='application/ld+json'>
{
  "@context": "http://www.schema.org",
  "@type": "Organization",
  "name": "Talk of the Sound",
  "url": "https://talkofthesound.com/",
  "sameAs": [
     "https://www.facebook.com/TalkoftheSound/",
     "https://twitter.com/talkofthesound/",
     "https://www.youtube.com/talkofthesound"
  ],
  "image": "https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/talkofthesound_wp/images/Dog-in-the-Fog-1.jpg",
  "description": "Talk of the Sound is a hyper-local news site, considered the source for news and information on the Sound Shore since 2008. Robert Cox is the Managing Editor & Publisher. You can advertise, subscribe, register for our daily email newsletter, listen to our podcasts, search our archives or provide send press releases or offer news tips and information."
}
</script>
<link rel="icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=270%2C270&#038;ssl=1" />
		<style id="wp-custom-css">
			.new-section {
    padding: 50px 0 50px;
}

.new-section h1 {
    font-size: 50px;
	  padding-bottom: 20px;
}

@media screen and (max-width: 900px) {
  .new-section h1 {
    font-size: 25px;
	  padding-bottom: 20px;
  }
}

.new-section-bottom {
    padding: 50px 0 50px;
}

.new-section-cta {
    background-color: #878A9B;
    max-width: 110%;
    padding: 50px 0 50px !important;
    margin: 0px -40px 0px -40px !important;
}

.new-section-cta p {
   color: white;
	 font-size: 20px;
	 font-weight: bold;
}

.new-section-cta a {
   color: white;
	 font-size: 20px;
	 font-weight: bold;
	 padding: 10px;
}

@media screen and (max-width: 900px) {
  .new-section-cta {
    background-color: #878A9B;
		margin: 0px !important

}
}

.section-cta {
    padding: 100px 0 100px;
}

.cta-button a{
	color: white;
}		</style>
		<style>
</style>
	<script>
		function ts_show_sidebar() {
			var x = document.getElementById("sidebar");

			if (x.className.indexOf("w3-show") == -1) {
				x.className += " w3-show";
			} else {
				x.className = x.className.replace(" w3-show", "");
			}
		}

		function ts_change_title() {
			var y = document.getElementById("ts-main-toggle");
			if (y.className.indexOf("toggled-on") == -1) {
				y.className += " toggled-on";
			} else {
				y.className = y.className.replace(" toggled-on", "");
			}
			ts_show_sidebar();
		}


		function toggle_visibility(thisParent) {
			if (thisParent.tagName == "ASIDE") {
				if (thisParent.className.indexOf("noDisplay") == -1) {
					thisParent.className += " noDisplay";
				} else {
					thisParent.className = thisParent.className.replace(" noDisplay", "");
				}
			}
		}

	</script>
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/c7fcc613b4fecb699c2f8ce7f/4ccb25ff2abb310e3d532c00e.js");</script>
</head>

<body class="post-template-default single single-post postid-57686 single-format-standard wp-embed-responsive">


<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
	<div class="site-branding">
		<div class="header-back" style="width:100%;background-color: black;">
			<img alt='Talk of the Sound Banner' title='Talk of the Sound' src="https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/talkofthesound_wp/images/Dog-in-the-Fog-1.jpg" style="width:100%;">
						<div class="site-identifier" style="text-align: left;position:absolute; top:1rem;width:100%">
				<div class="site-title" style="position:relative;">
					<a href="https://talkofthesound.com/" style="margin:0 auto;color:white;padding: 6px;" rel="home">Talk of the Sound</a>
				</div>					<span class="site-description" style="position:relative; color:white;"><p style="padding: 6px; display: inline;">Considered the Source Since 2008</p></span>
							</div>
			<button id="ts-main-toggle" class="secondary-toggle"
					onclick="ts_show_sidebar()">Menu and widgets</button>
		</div>
	</div><!-- .site-branding -->
</header><!-- .site-header -->
<div id="page" class="hfeed site">
	<div id="sidebar" class="sidebar">
			<div id="secondary" class="secondary">
        <button class="secondary-toggle toggled-on white" onclick="ts_change_title()" aria-expanded="true">Menu and widgets</button>
		
		
					<div id="widget-area" class="widget-area" role="complementary">
				<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://talkofthesound.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit screen-reader-text" value="Search" />
			</form></aside><aside id="listcategorypostswidget-2" class="widget widget_listcategorypostswidget"><h2 class="widget-title">Featured Stories</h2><ul class="lcp_catlist" id="lcp_instance_listcategorypostswidget-2"></ul><a href="" > </a></aside>
<aside id="wpp-2" class="widget popular-posts">
<h2 class="widget-title">Most Discussed Stories</h2><!-- cached -->
<!-- WordPress Popular Posts -->

<ul class="wpp-list">
<li>
<a href="https://talkofthesound.com/2020/07/20/nrpd-police-commissioner-flat-out-lied-to-paint-false-narrative-to-justify-killing-of-black-new-rochelle-man/" class="wpp-post-title" target="_self">NRPD Police Commissioner Flat Out Lied to Paint False Narrative to Justify Killing of Black New Rochelle Man</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">12 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/07/22/new-rochelle-mayor-unable-to-explain-dubious-claim-mckenna-unaware-of-kamal-flowers-criminal-record/" class="wpp-post-title" target="_self">New Rochelle Mayor Unable to Explain Dubious Claim, McKenna Unaware of Kamal Flowers Criminal Record</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">3 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/07/14/new-rochelle-public-works-commissioner-unexpectedly-resigned/" class="wpp-post-title" target="_self">New Rochelle Public Works Commissioner Unexpectedly Resigned</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">2 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/07/14/a-history-of-new-rochelle-alternative-high-school-1970-to-2020/" class="wpp-post-title" target="_self">A History of New Rochelle Alternative High School 1970 to 2020</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">2 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/07/24/new-rochelle-ida-tops-1-billion-in-total-project-value-on-25-projects-with-22-million-in-pilots-and-tax-exemptions/" class="wpp-post-title" target="_self">New Rochelle IDA Tops $1 Billion in Total Project Value on 25 Projects with $22 Million in PILOTS and Tax Exemptions</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">1 comment</span></span>
</li>
</ul>

</aside>
<aside id="calendar-2" class="widget widget_calendar"><h2 class="widget-title">Archive Calendar</h2><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>July 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td><a href="https://talkofthesound.com/2020/07/01/" aria-label="Posts published on July 1, 2020">1</a></td><td><a href="https://talkofthesound.com/2020/07/02/" aria-label="Posts published on July 2, 2020">2</a></td><td><a href="https://talkofthesound.com/2020/07/03/" aria-label="Posts published on July 3, 2020">3</a></td><td><a href="https://talkofthesound.com/2020/07/04/" aria-label="Posts published on July 4, 2020">4</a></td><td><a href="https://talkofthesound.com/2020/07/05/" aria-label="Posts published on July 5, 2020">5</a></td>
	</tr>
	<tr>
		<td><a href="https://talkofthesound.com/2020/07/06/" aria-label="Posts published on July 6, 2020">6</a></td><td><a href="https://talkofthesound.com/2020/07/07/" aria-label="Posts published on July 7, 2020">7</a></td><td><a href="https://talkofthesound.com/2020/07/08/" aria-label="Posts published on July 8, 2020">8</a></td><td><a href="https://talkofthesound.com/2020/07/09/" aria-label="Posts published on July 9, 2020">9</a></td><td><a href="https://talkofthesound.com/2020/07/10/" aria-label="Posts published on July 10, 2020">10</a></td><td><a href="https://talkofthesound.com/2020/07/11/" aria-label="Posts published on July 11, 2020">11</a></td><td><a href="https://talkofthesound.com/2020/07/12/" aria-label="Posts published on July 12, 2020">12</a></td>
	</tr>
	<tr>
		<td><a href="https://talkofthesound.com/2020/07/13/" aria-label="Posts published on July 13, 2020">13</a></td><td><a href="https://talkofthesound.com/2020/07/14/" aria-label="Posts published on July 14, 2020">14</a></td><td><a href="https://talkofthesound.com/2020/07/15/" aria-label="Posts published on July 15, 2020">15</a></td><td><a href="https://talkofthesound.com/2020/07/16/" aria-label="Posts published on July 16, 2020">16</a></td><td><a href="https://talkofthesound.com/2020/07/17/" aria-label="Posts published on July 17, 2020">17</a></td><td><a href="https://talkofthesound.com/2020/07/18/" aria-label="Posts published on July 18, 2020">18</a></td><td>19</td>
	</tr>
	<tr>
		<td><a href="https://talkofthesound.com/2020/07/20/" aria-label="Posts published on July 20, 2020">20</a></td><td><a href="https://talkofthesound.com/2020/07/21/" aria-label="Posts published on July 21, 2020">21</a></td><td><a href="https://talkofthesound.com/2020/07/22/" aria-label="Posts published on July 22, 2020">22</a></td><td><a href="https://talkofthesound.com/2020/07/23/" aria-label="Posts published on July 23, 2020">23</a></td><td><a href="https://talkofthesound.com/2020/07/24/" aria-label="Posts published on July 24, 2020">24</a></td><td><a href="https://talkofthesound.com/2020/07/25/" aria-label="Posts published on July 25, 2020">25</a></td><td>26</td>
	</tr>
	<tr>
		<td id="today"><a href="https://talkofthesound.com/2020/07/27/" aria-label="Posts published on July 27, 2020">27</a></td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://talkofthesound.com/2020/06/">&laquo; Jun</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-42975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42975"><a href="https://talkofthesound.com/about/">Who We Are</a></li>
<li id="menu-item-42976" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42976"><a href="https://talkofthesound.com/contact/">Get in Touch with Us Today</a></li>
<li id="menu-item-42970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42970"><a href="https://talkofthesound.com/newsletter/">Subscribe to the Talk of the Sound Daily Journal</a></li>
<li id="menu-item-42973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42973"><a href="https://talkofthesound.com/live-radio-and-podcast/">Live Radio and Podcast</a></li>
<li id="menu-item-42972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42972"><a href="https://talkofthesound.com/terms-of-service/">Terms of Service</a></li>
</ul></div></aside><aside id="displaycategorieswidget-2" class="widget DisplayCategoriesWidget"><h2 class="widget-title">Categories</h2>    <form action="https://talkofthesound.com" method="get">
    <div>
    <select  name='cat2' id='cat2' class='postform' >
	<option value='-1'>Reset Filter</option>
	<option class="level-0" value="1145">-1&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1078">123&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1144">245&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1146">246&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1143">390&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="387">Arts&nbsp;&nbsp;(393)</option>
	<option class="level-0" value="395">Courts&nbsp;&nbsp;(252)</option>
	<option class="level-0" value="279">Dining&nbsp;&nbsp;(228)</option>
	<option class="level-0" value="245">Education&nbsp;&nbsp;(2,958)</option>
	<option class="level-0" value="396">Environment&nbsp;&nbsp;(161)</option>
	<option class="level-0" value="1060">fb&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="398">Featured&nbsp;&nbsp;(424)</option>
	<option class="level-0" value="384">General&nbsp;&nbsp;(219)</option>
	<option class="level-0" value="247">Legal&nbsp;&nbsp;(192)</option>
	<option class="level-0" value="843">Library&nbsp;&nbsp;(348)</option>
	<option class="level-0" value="390">Mamaroneck&nbsp;&nbsp;(245)</option>
	<option class="level-0" value="1077">med&nbsp;&nbsp;(28)</option>
	<option class="level-0" value="289">Media&nbsp;&nbsp;(81)</option>
	<option class="level-0" value="389">Medicine&nbsp;&nbsp;(493)</option>
	<option class="level-0" value="391">MTA&nbsp;&nbsp;(33)</option>
	<option class="level-0" value="270">Municipal&nbsp;&nbsp;(1,401)</option>
	<option class="level-0" value="246">New Rochelle&nbsp;&nbsp;(5,131)</option>
	<option class="level-0" value="244">New York State&nbsp;&nbsp;(705)</option>
	<option class="level-0" value="275">Obituaries&nbsp;&nbsp;(697)</option>
	<option class="level-0" value="304">Opinion&nbsp;&nbsp;(71)</option>
	<option class="level-0" value="392">Pelham&nbsp;&nbsp;(220)</option>
	<option class="level-0" value="1038">Podcast&nbsp;&nbsp;(8)</option>
	<option class="level-0" value="724">Politics&nbsp;&nbsp;(288)</option>
	<option class="level-0" value="267">Port Chester&nbsp;&nbsp;(147)</option>
	<option class="level-0" value="295">PSC&nbsp;&nbsp;(111)</option>
	<option class="level-0" value="272">Real Estate&nbsp;&nbsp;(209)</option>
	<option class="level-0" value="274">Religion&nbsp;&nbsp;(115)</option>
	<option class="level-0" value="302">Rye&nbsp;&nbsp;(198)</option>
	<option class="level-0" value="393">Safety&nbsp;&nbsp;(1,255)</option>
	<option class="level-0" value="383">Sports&nbsp;&nbsp;(2,334)</option>
	<option class="level-0" value="281">Technology&nbsp;&nbsp;(118)</option>
	<option class="level-0" value="252">Transportation&nbsp;&nbsp;(135)</option>
	<option class="level-0" value="386">USA&nbsp;&nbsp;(258)</option>
	<option class="level-0" value="394">Weather&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="243">Westchester&nbsp;&nbsp;(919)</option>
</select>
    <script type="text/javascript">
        <!--
        var dropdown2 = document.getElementById("cat2");
        function onCatChange2() {
            if ( dropdown2.options[dropdown2.selectedIndex].value > 0 ) {
                location.href = "https://talkofthesound.com/?cat="+dropdown2.options[dropdown2.selectedIndex].value;
            }
        }
        dropdown2.onchange = onCatChange2;
        -->
    </script>
    </div>
    </form>
    
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="navigation-social-bookmarks">
<ul class="social-bookmarks">
<li>
<a href="http://www.facebook.com/talkofthesound/"><i class="fa fa-facebook"></i></a>
</li>
<li>
<a href="http://twitter.com/talkofthesound/"><i class="fa fa-twitter"></i></a>
</li>
	<li>
<a href="http://talkofthesound.com/feed/"><i class="fa fa-rss"></i></a>
</li>
<li><a href="http://YouTube.com/talkofthesound"><i class="fa fa-youtube"></i></a>
</li>
</ul>
</div>
</div></aside>			</div><!-- .widget-area -->
		
	</div><!-- .secondary -->

	</div><!-- .sidebar -->
	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		<div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<a class="advertisement" href="http://librett.com"><img alt='Advertisement - Librett' src="/ads/librett-ad-final.gif"></a></div>

<article id="post-57686" class="single post-57686 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-new-rochelle">
	
		<div class="post-thumbnail">
			<img width="825" height="510" src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?resize=825%2C510&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-lazy-src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/FA3385D0-7093-4E08-9941-147AAC0D87C6.jpeg?resize=825%2C510&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />	</div><!-- .post-thumbnail -->

	

	<header class="entry-header">
		<h1 class="entry-title">New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes</h1>			<div class="the-author">Written By: Robert Cox</div>	</header><!-- .entry-header -->

			<div class="entry-content">
			
<p>NEW ROCHELLE, NY &#8212; The New Rochelle Veterans Advisory Committee was joined by officials from American Legion Post 8 and the City of New Rochelle to celebrate the installation of “Hometown Heroes” banners this morning at Faneuil Park.</p>



<p><div class="jetpack-video-wrapper"><iframe title="New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes" width="660" height="371" src="https://www.youtube.com/embed/AHEZ5XfW9NA?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></p>



<p>Veterans, banner sponsors and military moms were on hand along with Cpl. Guadalupe Mendoza.</p>



<div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?w=660&#038;ssl=1" alt class="wp-image-57684 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?w=353&amp;ssl=1 353w, https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?resize=197%2C300&amp;ssl=1 197w" data-lazy-sizes="(max-width: 353px) 100vw, 353px" data-lazy-src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?w=660&#038;ssl=1" alt="" class="wp-image-57684" srcset="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?w=353&amp;ssl=1 353w, https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/07/7FA8083E-F351-45DA-AEC7-90FFDED1C0E7.jpeg?resize=197%2C300&amp;ssl=1 197w" sizes="(max-width: 353px) 100vw, 353px" data-recalc-dims="1" /></noscript></figure></div>



<p>Afterwards, there was a walking tour to view the banners which are installed along Main and Huguenot Streets between Echo and Stephenson Boulevard.</p>
<div id="ess-main-wrapper">
	<div id="ess-wrap-inline-networks" class="ess-inline-networks-container ess-clear ess-inline-bottom ess-diagonal-icon ess-inline-layout-one">
		<ul class="ess-social-network-lists">
							<li class="ess-social-networks ess-facebook ess-spacing ess-social-sharing">
					<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;t=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="facebook" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-facebook" data-tip="Facebook"></span>
													<span class="ess-text">Facebook</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-twitter ess-spacing ess-social-sharing">
					<a href="http://twitter.com/share?text=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;via=talkofthesound" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="twitter" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-twitter" data-tip="Twitter"></span>
													<span class="ess-text">Twitter</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-linkedin ess-spacing ess-social-sharing">
					<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="linkedin" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-linkedin" data-tip="Linkedin"></span>
													<span class="ess-text">LinkedIn</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-googleplus ess-spacing ess-social-sharing">
					<a href="https://plus.google.com/share?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;t=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="googleplus" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-googleplus" data-tip="Googleplus"></span>
													<span class="ess-text">Google+</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-stumbleupon ess-spacing ess-social-sharing">
					<a href="http://www.stumbleupon.com/badge?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="stumbleupon" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-stumbleupon" data-tip="Stumbleupon"></span>
													<span class="ess-text">StumbleUpon</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-pinterest ess-spacing ess-social-sharing">
					<a href="#" class="ess-social-network-link ess-social-share-pinterest ess-display-counts" rel="nofollow" data-social-name="pinterest" data-min-count="0" data-post-id="57686" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-pinterest" data-tip="Pinterest"></span>
													<span class="ess-text">Pinterest</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
										<li class="ess-all-networks ess-social-networks">
					<div class="ess-social-network-link">
						<span class="ess-all-networks-button"><i aria-hidden="true" class="fa fa-ellipsis-h"></i></span>
					</div>
				</li>
										<li class="ess-total-share ess-social-networks" data-post-id="57686"><div class="ess-total-share-block"><i class="fa fa-share-alt"></i> <span class="ess-total-count"></span><span class="ess-share-text">Shares</span></div></li>
					</ul>
	</div>
</div>
		</div><!-- .entry-content -->
		
		<footer class="entry-footer">
			<span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" rel="bookmark"><time class="entry-date published" datetime="2020-07-27T13:29:16-04:00">July 27, 2020</time><time class="updated" datetime="2020-07-27T13:30:08-04:00">July 27, 2020</time></a></span><span class="byline"><span class="author vcard"><span class="screen-reader-text">Author </span><a class="url fn n" href="https://talkofthesound.com/author/robert-cox/">Robert Cox</a></span></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://talkofthesound.com/category/front-page/featured/" rel="category tag">Featured</a>, <a href="https://talkofthesound.com/category/front-page/new-rochelle/" rel="category tag">New Rochelle</a></span>					</footer><!-- .entry-footer -->
	
</article><!-- #post-## -->

<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&#038;postid=57686&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.7.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=3acbc57c82fb305eec3522408e5ac16c91e5b1fb#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://talkofthesound.com/2020/07/27/reopening-schools-hudson-valley-school-chiefs-gird-for-hybrid-learning-in-september/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Reopening schools: Hudson Valley school chiefs gird for &#8216;hybrid&#8217; learning in September</span></a></div></div>
	</nav><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TOTS 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-5602862681328597"
     data-ad-slot="9436859678"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

		</main><!-- .site-main -->
	</div><!-- .content-area -->


</div><!-- .site-content -->

<footer id="colophon" class="site-footer" role="contentinfo">
    <div class="site-info">
        		<a href="/about" title="About Talk of the Sound">About</a> | <a href="/contact" title="Contact Talk of the Sound">Contact</a> | <a href="/terms-of-service/" title="Terms of Service">Terms of Service</a> | © 2008-2020 Talk of the Sound. All rights reserved. | <a href="/sitemap/">Sitemap<a>
		    </div><!-- .site-info -->
</footer><!-- .site-footer -->

</div><!-- .site -->

<div id="ess-main-wrapper">
	<div class="ess-popup-overlay"></div>
	<div class="ess-pinterest-popup-overlay"></div>
	<div class="ess-popup-wrapper">
		<div class="ess-popup-close"><i class="fa fa-close"></i></div>
		<div id="ess-wrap-inline-networks">
			<ul class="ess-social-network-lists">
									<li class="ess-social-networks ess-facebook ess-spacing ess-social-sharing">
						<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;t=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-facebook"></span>
							<span class="ess-text">Facebook</span>
						</a>
					</li>
									<li class="ess-social-networks ess-twitter ess-spacing ess-social-sharing">
						<a href="http://twitter.com/share?text=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;via=talkofthesound" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-twitter"></span>
							<span class="ess-text">Twitter</span>
						</a>
					</li>
									<li class="ess-social-networks ess-googleplus ess-spacing ess-social-sharing">
						<a href="https://plus.google.com/share?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;t=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-googleplus"></span>
							<span class="ess-text">Google+</span>
						</a>
					</li>
									<li class="ess-social-networks ess-linkedin ess-spacing ess-social-sharing">
						<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-linkedin"></span>
							<span class="ess-text">LinkedIn</span>
						</a>
					</li>
									<li class="ess-social-networks ess-pinterest ess-spacing ess-social-sharing">
						<a href="#" class="ess-social-share-pinterest" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-pinterest"></span>
							<span class="ess-text">Pinterest</span>
						</a>
					</li>
									<li class="ess-social-networks ess-stumbleupon ess-spacing ess-social-sharing">
						<a href="http://www.stumbleupon.com/badge?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-stumbleupon"></span>
							<span class="ess-text">StumbleUpon</span>
						</a>
					</li>
									<li class="ess-social-networks ess-tumblr ess-spacing ess-social-sharing">
						<a href="https://www.tumblr.com/share?v=3&#038;u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;t=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-tumblr"></span>
							<span class="ess-text">Tumblr</span>
						</a>
					</li>
									<li class="ess-social-networks ess-blogger ess-spacing ess-social-sharing">
						<a href="https://www.blogger.com/blog_this.pyra?t&#038;u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;n=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-blogger"></span>
							<span class="ess-text">Blogger</span>
						</a>
					</li>
									<li class="ess-social-networks ess-myspace ess-spacing ess-social-sharing">
						<a href="https://myspace.com/post?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-myspace"></span>
							<span class="ess-text">Myspace</span>
						</a>
					</li>
									<li class="ess-social-networks ess-delicious ess-spacing ess-social-sharing">
						<a href="https://delicious.com/post?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-delicious"></span>
							<span class="ess-text">Delicious</span>
						</a>
					</li>
									<li class="ess-social-networks ess-yahoomail ess-spacing ess-social-sharing">
						<a href="http://compose.mail.yahoo.com/?body=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-yahoomail"></span>
							<span class="ess-text">Yahoo Mail</span>
						</a>
					</li>
									<li class="ess-social-networks ess-gmail ess-spacing ess-social-sharing">
						<a href="https://mail.google.com/mail/u/0/?view=cm&#038;fs=1&#038;su=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes&#038;body=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;ui=2&#038;tf=1" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-gmail"></span>
							<span class="ess-text">Gmail</span>
						</a>
					</li>
									<li class="ess-social-networks ess-newsvine ess-spacing ess-social-sharing">
						<a href="http://www.newsvine.com/_tools/seed&#038;save?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;h=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-newsvine"></span>
							<span class="ess-text">Newsvine</span>
						</a>
					</li>
									<li class="ess-social-networks ess-digg ess-spacing ess-social-sharing">
						<a href="http://digg.com/submit?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-digg"></span>
							<span class="ess-text">Digg</span>
						</a>
					</li>
									<li class="ess-social-networks ess-friendfeed ess-spacing ess-social-sharing">
						<a href="http://friendfeed.com/?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-friendfeed"></span>
							<span class="ess-text">FriendFeed</span>
						</a>
					</li>
									<li class="ess-social-networks ess-buffer ess-spacing ess-social-sharing">
						<a href="https://bufferapp.com/add?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-buffer"></span>
							<span class="ess-text">Buffer</span>
						</a>
					</li>
									<li class="ess-social-networks ess-reddit ess-spacing ess-social-sharing">
						<a href="http://www.reddit.com/submit?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F&#038;title=New%20Rochelle%20Installs%20Banners%20Honoring%20Service%20of%20Military%20Veterans%3A%20Hometown%20Heroes" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-reddit"></span>
							<span class="ess-text">Reddit</span>
						</a>
					</li>
									<li class="ess-social-networks ess-vkontakte ess-spacing ess-social-sharing">
						<a href="http://vk.com/share.php?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-vkontakte"></span>
							<span class="ess-text">VKontakte</span>
						</a>
					</li>
							</ul>
		</div>
	</div>
</div>
<div id="ess-main-wrapper">
	<div class="ess-pinterest-img-picker-popup">
		<h3 class="ess-pinterest-popup-title">Pin It on Pinterest</h3>
		<div class="ess-pinterest-popup-close"><i class="fa fa-close"></i></div>
		<div class="ess-social-pin-images" data-permalink="https://talkofthesound.com/2020/07/27/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes/" data-title="New Rochelle Installs Banners Honoring Service of Military Veterans: Hometown Heroes" data-post_id="57686"></div>
		<div class="ess-no-pinterest-img-found"></div>
	</div>
</div>
<script src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/photon/photon.min.js'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/jquery-tiptip/jquery.tipTip.min.js?ver=3.5.4'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/jquery-idletimer/idle-timer.min.js?ver=1.1.0'></script>
<script>
var easy_social_sharing_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","page_url":"https:\/\/talkofthesound.com\/2020\/07\/27\/new-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes\/","update_share_nonce":"738e6adf51","shares_count_nonce":"25c57b2529","all_network_shares_count_nonce":"91714e6387","total_counts_nonce":"b89da44cd8","i18n_no_img_message":"No images found.","network_data":{"facebook":{"network_id":"1","network_name":"facebook","network_desc":"Facebook","network_order":"1","network_count":"0","is_api_support":"1"},"twitter":{"network_id":"2","network_name":"twitter","network_desc":"Twitter","network_order":"2","network_count":"0","is_api_support":"0"},"linkedin":{"network_id":"3","network_name":"linkedin","network_desc":"Linkedin","network_order":"3","network_count":"0","is_api_support":"1"},"googleplus":{"network_id":"4","network_name":"googleplus","network_desc":"Googleplus","network_order":"4","network_count":"0","is_api_support":"1"},"stumbleupon":{"network_id":"5","network_name":"stumbleupon","network_desc":"Stumbleupon","network_order":"5","network_count":"0","is_api_support":"1"},"pinterest":{"network_id":"6","network_name":"pinterest","network_desc":"Pinterest","network_order":"6","network_count":"0","is_api_support":"1"}}};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/frontend/easy-social-sharing.min.js?ver=1.3.3'></script>
<script src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/skip-link-focus-fix.js?ver=20141028'></script>
<script src='https://c0.wp.com/c/5.4.2/wp-includes/js/comment-reply.min.js'></script>
<script>
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/functions.js?ver=20171218'></script>
<script src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script src='https://c0.wp.com/p/jetpack/8.7.1/modules/theme-tools/responsive-videos/responsive-videos.min.js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&postid=57686&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3acbc57c82fb305eec3522408e5ac16c91e5b1fb#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&postid=57686&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3acbc57c82fb305eec3522408e5ac16c91e5b1fb#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F07%2F27%2Fnew-rochelle-installs-banners-honoring-service-of-military-veterans-hometown-heroes%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202031.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'175374175',post:'57686',tz:'-4',srv:'talkofthesound.com'} ]);
	_stq.push([ 'clickTrackerInit', '175374175', '57686' ]);
</script>
<script>
    var these = document.getElementById('secondary').getElementsByClassName('widget-title');
    if (these.length) {
        for (var n = 0, m = these.length; n < m; n++) {
            var thisWidghet = these[n];
            if (thisWidghet.tagName == "H2") {
                thisWidghet.addEventListener('click', function () {
                    var thisParent = this.parentNode;
                    if (thisParent.tagName == "ASIDE") {
                        toggle_visibility(thisParent);
                    }
                }, false);
            }
        }
    }
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
//	(adsbygoogle = window.adsbygoogle || []).push({
//		google_ad_client: "ca-pub-5602862681328597",
//		enable_page_level_ads: true
//	});
</script>
</body>
</html>
