<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://talkofthesound.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/html5.js"></script>
	<![endif]-->
	<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal | Talk of the Sound</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="NEW ROCHELLE, NY &#8212; The City School District of New Rochelle announced moments ago that Adofo Muhammad has withdrawn as the incoming Principal of New Rochelle&#8230;" />
<meta property="og:image" content="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/05/807FBE3D-00B9-4D22-B427-D53304804785.jpeg?fit=1167%2C828&amp;ssl=1" />
<meta property="og:image:width" content="1167" />
<meta property="og:image:height" content="828" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal | Talk of the Sound" />
<meta property="og:description" content="NEW ROCHELLE, NY &#8212; The City School District of New Rochelle announced moments ago that Adofo Muhammad has withdrawn as the incoming Principal of New Rochelle High School." />
<meta property="og:url" content="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/" />
<meta property="og:site_name" content="Talk of the Sound" />
<meta property="article:published_time" content="2020-05-07T22:43+00:00" />
<meta property="article:modified_time" content="2020-05-07T22:43+00:00" />
<meta property="og:updated_time" content="2020-05-07T22:43+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal | Talk of the Sound" />
<meta name="twitter:description" content="NEW ROCHELLE, NY &#8212; The City School District of New Rochelle announced moments ago that Adofo Muhammad has withdrawn as the incoming Principal of New Rochelle High School." />
<meta name="twitter:image" content="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/05/807FBE3D-00B9-4D22-B427-D53304804785.jpeg?fit=1167%2C828&amp;ssl=1" />
<meta name="twitter:image:width" content="1167" />
<meta name="twitter:image:height" content="828" />
<link rel="canonical" href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://talkofthesound.com/","name":"Talk of the Sound"}},{"@type":"ListItem","position":2,"item":{"@id":"https://talkofthesound.com/category/front-page/","name":"Front-Page"}},{"@type":"ListItem","position":3,"item":{"@id":"https://talkofthesound.com/category/front-page/education/","name":"Education"}},{"@type":"ListItem","position":4,"item":{"@id":"https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/","name":"Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 0.27ms meta | 0.54ms boot -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-7445625-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-7445625-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentyfifteen-jetpack-css'  href='https://c0.wp.com/p/jetpack/8.5/modules/theme-tools/compat/twentyfifteen.css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/style.min.css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/theme.min.css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dashicons.min.css' media='all' />
<link rel='stylesheet' id='cwp-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/comments-widget-plus/assets/css/cwp.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=1.3.2' media='all' />
<link rel='stylesheet' id='easy-social-sharing-general-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/css/easy-social-sharing.css?ver=1.3.2' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-Phone-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/intlTelInput.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-Country-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/countrySelect.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='Rich_Web_Forms-admin-ui-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/rw-jquery-ui.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Style/richwebicons.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' media='all' />
<link rel='stylesheet' id='twentyfifteen-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/style.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/talkofthesound_wp/style.css?ver=1.39' media='all' />
<link rel='stylesheet' id='twentyfifteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto+Sans%3A400italic%2C700italic%2C400%2C700%7CNoto+Serif%3A400italic%2C700italic%2C400%2C700%7CInconsolata%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;display=fallback' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.5/_inc/genericons/genericons/genericons.css' media='all' />
<link rel='stylesheet' id='twentyfifteen-block-style-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/blocks.css?ver=20190102' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfifteen-ie-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/ie.css?ver=20170916' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentyfifteen-ie7-css'  href='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/css/ie7.css?ver=20141210' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.5/css/jetpack.css' media='all' />
<script>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/talkofthesound.com","hash_tracking":"false"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery.js'></script>
<script src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/ui/core.min.js'></script>
<script>
var object = {"ajaxurl":"https:\/\/talkofthesound.com\/wp-admin\/admin-ajax.php"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/Rich-Web-Forms-Widget.js?ver=5.4.1'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/intlTelInput.min.js?ver=5.4.1'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/form-forms/Scripts/countrySelect.min.js?ver=5.4.1'></script>
<script>
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/talkofthesound.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"56659","token":"5d81f05fde","debug":""};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<link rel='https://api.w.org/' href='https://talkofthesound.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://talkofthesound.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://talkofthesound.com/wp-includes/wlwmanifest.xml" /> 
	<script type="text/javascript">
	    var ajaxurl = 'https://talkofthesound.com/wp-admin/admin-ajax.php';
	</script>

	<style type="text/css">
		.ajax-calendar{
			position:relative;
		}

		#ajax_ac_widget th {
		background: none repeat scroll 0 0 #2cb2bc;
		color: #FFFFFF;
		font-weight: normal;
		padding: 5px 1px;
		text-align: center;
		 font-size: 16px;
		}
		#ajax_ac_widget {
			padding: 5px;
		}
		
		#ajax_ac_widget td {
			border: 1px solid #CCCCCC;
			text-align: center;
		}
		
		#my-calendar a {
			background: none repeat scroll 0 0 #008000;
			color: #FFFFFF;
			display: block;
			padding: 6px 0;
			width: 100% !important;
		}
		#my-calendar{
			width:100%;
		}
		
		
		#my_calender span {
			display: block;
			padding: 6px 0;
			width: 100% !important;
		}
		
		#today a,#today span {
			   background: none repeat scroll 0 0 #2cb2bc !important;
			color: #FFFFFF;
		}
		#ajax_ac_widget #my_year {
			float: right;
		}
		.select_ca #my_month {
			float: left;
		}

	</style>
	<meta name="generator" content="Site Kit by Google 1.8.0" /><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>

<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-5602862681328597",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
					<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/cropped-ms-icon-310x310-1.png?fit=270%2C270&#038;ssl=1" />
		<style id="wp-custom-css">
			New Rochelle High School students have once again ranked their favorite teachers on the popular Ratemyteachers.com web site.  67 of 338 teachers made Honor Roll this year. The rankings are based on a raw score total determined by total number of votes cast by students multiplied by overall ratings average for each teacher. The Honor Roll represents those teachers who earned a 4.0 or higher average rating from their students, on a scale of 1 to 5. All rankings are based on survey data from Jan 1. 2006 until June 30, 2008.  Some teachers have since left the school.NRHS Top 20 Teachers of 20081. Duarte 299.22. Kopstein 220.03. Shultz 201.44. Gurney 177.65. Brown 162.86. Rose 151.27. Maire 150.48. Byrne 141.09. Gallino 136.910. Beck 133.011. Zimmerman 132.012. MacKay 129.513. Zeller 128.814. Monteleone 124.815. Bernero 124.816. Corcoran 122.217. Comerford 119.618. Fuller 115.019. Ciamei 112.520. MacHay 108.8&nbsp;NRHS Honor Roll for 2008: Bernero 4.8 Billig 4.4 Brock 4.9 Brown 4.0 Browne 4.4 Byrne 4.4 Byrne 4.7 Castellanos 4.4 Ciamei 4.5 Ciccone 4.9 Comerford 4.6 Cooper 4.3 Corcoran 4.7 Costa 4.3 Duarte 4.4 Elia 4.4 Fry 5.0 Fuller 5.0 Funigiello 4.7 Gallino 4.0 Gardner 4.4 Gierer 4.9 Green 4.2 Guccione 4.2 Gunther 4.5 Guo 4.3 Gurney 4.8 Hershey 4.1 Kopstein 4.4 Kronovet 4.1 Lally 4.2 Landskowsky 4.1 Listwan 4.3 Lynn 4.1 Maire 4.7 May 4.1 McCaul 4.6 Minchin 4.3 Molloy 4.3 Monaco 4.4 Monteleone 4.8 Morgan 4.2 Morganti 4.4 Morrison 4.7 Nelson 4.3 Ostrofsky 4.7 Preston 4.6 Prikasky 4.7 Raboy 4.8 Reidy 4.4 Rhett 4.8 Rose 4.2 Rubins 4.1 Salotollo 4.1 Schomber 4.3 Seaboldt 4.2 Sternfeld 4.6 Stirpe 4.4 Tedesco 4.3 Vinelli 4.5 Wallace 4.5 Weiner 4.0 Wood 4.5 Woodworth 4.4 Yazurlo 4.6 Zeller 4.6 Zimmerman 4.0.		</style>
		<style>
</style>
	<script>
		function ts_show_sidebar() {
			var x = document.getElementById("sidebar");

			if (x.className.indexOf("w3-show") == -1) {
				x.className += " w3-show";
			} else {
				x.className = x.className.replace(" w3-show", "");
			}
		}

		function ts_change_title() {
			var y = document.getElementById("ts-main-toggle");
			if (y.className.indexOf("toggled-on") == -1) {
				y.className += " toggled-on";
			} else {
				y.className = y.className.replace(" toggled-on", "");
			}
			ts_show_sidebar();
		}


		function toggle_visibility(thisParent) {
			if (thisParent.tagName == "ASIDE") {
				if (thisParent.className.indexOf("noDisplay") == -1) {
					thisParent.className += " noDisplay";
				} else {
					thisParent.className = thisParent.className.replace(" noDisplay", "");
				}
			}
		}

	</script>
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/c7fcc613b4fecb699c2f8ce7f/4ccb25ff2abb310e3d532c00e.js");</script>
</head>

<body class="post-template-default single single-post postid-56659 single-format-standard wp-embed-responsive">

<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner">
	<div class="site-branding">
		<div class="header-back" style="width:100%;background-color: black;">
			<img alt='Talk of the Sound Banner' title='Talk of the Sound' src="https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/talkofthesound_wp/images/Dog-in-the-Fog-1.jpg" style="width:100%;">
						<div class="site-identifier" style="text-align: left;position:absolute; top:1rem;width:100%">
				<h1 class="site-title" style="position:relative;">
					<a href="https://talkofthesound.com/" style="margin:0 auto;color:white;padding: 6px;" rel="home">Talk of the Sound</a>
				</h1>					<span class="site-description" style="position:relative; color:white;"><p style="padding: 6px; display: inline;">Considered the Source Since 2008</p></span>
							</div>
			<button id="ts-main-toggle" class="secondary-toggle"
					onclick="ts_show_sidebar()">Menu and widgets</button>
		</div>
	</div><!-- .site-branding -->
</header><!-- .site-header -->
<div id="page" class="hfeed site">
	<div id="sidebar" class="sidebar">
			<div id="secondary" class="secondary">
        <button class="secondary-toggle toggled-on white" onclick="ts_change_title()" aria-expanded="true">Menu and widgets</button>
					<nav id="site-navigation" class="main-navigation" role="navigation">
							</nav><!-- .main-navigation -->
		
		
					<div id="widget-area" class="widget-area" role="complementary">
				<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://talkofthesound.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit screen-reader-text" value="Search" />
			</form></aside><aside id="listcategorypostswidget-2" class="widget widget_listcategorypostswidget"><h2 class="widget-title">Featured Stories</h2><ul class="lcp_catlist" id="lcp_instance_listcategorypostswidget-2"><li ><a href="https://talkofthesound.com/2020/05/06/get-on-ballot-for-new-rochelle-school-board-election-with-one-simple-email/" title="Get on the Ballot for New Rochelle School Board Election with one Simple Email">Get on the Ballot for New Rochelle School Board Election with one Simple Email</a>  </li><li ><a href="https://talkofthesound.com/2020/04/29/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-black-people-matrix/" title="What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix">What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix</a>  </li><li ><a href="https://talkofthesound.com/2020/05/01/mamaroneck-board-of-education-fears-drastic-revenue-shortfalls/" title="Mamaroneck Board of Education Fears Drastic Revenue Shortfalls">Mamaroneck Board of Education Fears Drastic Revenue Shortfalls</a>  </li><li ><a href="https://talkofthesound.com/2020/04/29/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-black-people-matrix/" title="What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix">What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix</a>  </li><li ><a href="https://talkofthesound.com/2020/04/27/talk-of-the-sound-podcast-s01e21/" title="Talk of the Sound Podcast S01E21">Talk of the Sound Podcast S01E21</a>  </li></ul><a href="https://talkofthesound.com/category/front-page/featured-story/" > </a></aside>
<aside id="wpp-2" class="widget popular-posts">
<h2 class="widget-title">Most Discussed Stories</h2><!-- cached -->
<!-- WordPress Popular Posts -->

<ul class="wpp-list">
<li>
<a href="https://talkofthesound.com/2020/04/29/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-black-people-matrix/" class="wpp-post-title" target="_self">What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">5 comments</span></span>
</li>
<li class="current">
<a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/" class="wpp-post-title" target="_self">Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">4 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/04/29/message-from-adofo-muhammad-2/" class="wpp-post-title" target="_self">Message from Adofo Muhammad</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">3 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/05/03/who-is-michael-dowd/" class="wpp-post-title" target="_self">Who is Michael Dowd?</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">3 comments</span></span>
</li>
<li>
<a href="https://talkofthesound.com/2020/05/05/whats-the-deal-with-the-newly-hired-new-rochelle-high-school-principal-and-r-kelly/" class="wpp-post-title" target="_self">What’s the Deal with the Newly Hired New Rochelle High School Principal and R. Kelly?</a>
 <span class="wpp-meta post-stats"><span class="wpp-comments">3 comments</span></span>
</li>
</ul>

</aside>
<aside id="calendar-2" class="widget widget_calendar"><h2 class="widget-title">Archive Calendar</h2><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>May 2020</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="4" class="pad">&nbsp;</td><td><a href="https://talkofthesound.com/2020/05/01/" aria-label="Posts published on May 1, 2020">1</a></td><td><a href="https://talkofthesound.com/2020/05/02/" aria-label="Posts published on May 2, 2020">2</a></td><td><a href="https://talkofthesound.com/2020/05/03/" aria-label="Posts published on May 3, 2020">3</a></td>
	</tr>
	<tr>
		<td><a href="https://talkofthesound.com/2020/05/04/" aria-label="Posts published on May 4, 2020">4</a></td><td><a href="https://talkofthesound.com/2020/05/05/" aria-label="Posts published on May 5, 2020">5</a></td><td><a href="https://talkofthesound.com/2020/05/06/" aria-label="Posts published on May 6, 2020">6</a></td><td><a href="https://talkofthesound.com/2020/05/07/" aria-label="Posts published on May 7, 2020">7</a></td><td id="today"><a href="https://talkofthesound.com/2020/05/08/" aria-label="Posts published on May 8, 2020">8</a></td><td>9</td><td>10</td>
	</tr>
	<tr>
		<td>11</td><td>12</td><td>13</td><td>14</td><td>15</td><td>16</td><td>17</td>
	</tr>
	<tr>
		<td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td><td>24</td>
	</tr>
	<tr>
		<td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://talkofthesound.com/2020/04/">&laquo; Apr</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-42975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42975"><a href="https://talkofthesound.com/about/">About</a></li>
<li id="menu-item-42976" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42976"><a href="https://talkofthesound.com/contact/">Contact</a></li>
<li id="menu-item-42970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42970"><a href="https://talkofthesound.com/newsletter/">Newsletter</a></li>
<li id="menu-item-42973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42973"><a href="https://talkofthesound.com/podcast-2/">Live Radio &#038; Podcast</a></li>
<li id="menu-item-42972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42972"><a href="https://talkofthesound.com/terms-of-service/">Terms of Service</a></li>
</ul></div></aside><aside id="displaycategorieswidget-2" class="widget DisplayCategoriesWidget"><h2 class="widget-title">Categories</h2>    <form action="https://talkofthesound.com" method="get">
    <div>
    <select  name='cat2' id='cat2' class='postform' >
	<option value='-1'>Reset Filter</option>
	<option class="level-0" value="1044">Art&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="387">Arts&nbsp;&nbsp;(371)</option>
	<option class="level-0" value="395">Courts&nbsp;&nbsp;(244)</option>
	<option class="level-0" value="279">Dining&nbsp;&nbsp;(213)</option>
	<option class="level-0" value="245">Education&nbsp;&nbsp;(2,798)</option>
	<option class="level-0" value="396">Environment&nbsp;&nbsp;(156)</option>
	<option class="level-0" value="1060">fb&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="398">Featured&nbsp;&nbsp;(359)</option>
	<option class="level-0" value="1042">Featured Story&nbsp;&nbsp;(7)</option>
	<option class="level-0" value="384">General&nbsp;&nbsp;(209)</option>
	<option class="level-0" value="247">Legal&nbsp;&nbsp;(192)</option>
	<option class="level-0" value="843">Library&nbsp;&nbsp;(346)</option>
	<option class="level-0" value="390">Mamaroneck&nbsp;&nbsp;(203)</option>
	<option class="level-0" value="289">Media&nbsp;&nbsp;(63)</option>
	<option class="level-0" value="1041">Medical&nbsp;&nbsp;(33)</option>
	<option class="level-0" value="389">Medicine&nbsp;&nbsp;(435)</option>
	<option class="level-0" value="391">MTA&nbsp;&nbsp;(29)</option>
	<option class="level-0" value="270">Municipal&nbsp;&nbsp;(1,384)</option>
	<option class="level-0" value="246">New Rochelle&nbsp;&nbsp;(4,877)</option>
	<option class="level-0" value="244">New York State&nbsp;&nbsp;(651)</option>
	<option class="level-0" value="275">Obituaries&nbsp;&nbsp;(692)</option>
	<option class="level-0" value="304">Opinion&nbsp;&nbsp;(71)</option>
	<option class="level-0" value="392">Pelham&nbsp;&nbsp;(218)</option>
	<option class="level-0" value="1038">Podcast&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="724">Politics&nbsp;&nbsp;(254)</option>
	<option class="level-0" value="267">Port Chester&nbsp;&nbsp;(129)</option>
	<option class="level-0" value="295">PSC&nbsp;&nbsp;(111)</option>
	<option class="level-0" value="272">Real Estate&nbsp;&nbsp;(202)</option>
	<option class="level-0" value="274">Religion&nbsp;&nbsp;(114)</option>
	<option class="level-0" value="302">Rye&nbsp;&nbsp;(148)</option>
	<option class="level-0" value="393">Safety&nbsp;&nbsp;(1,175)</option>
	<option class="level-0" value="383">Sports&nbsp;&nbsp;(2,305)</option>
	<option class="level-0" value="281">Technology&nbsp;&nbsp;(114)</option>
	<option class="level-0" value="252">Transportation&nbsp;&nbsp;(132)</option>
	<option class="level-0" value="386">USA&nbsp;&nbsp;(225)</option>
	<option class="level-0" value="394">Weather&nbsp;&nbsp;(41)</option>
	<option class="level-0" value="243">Westchester&nbsp;&nbsp;(880)</option>
	<option class="level-0" value="1043">Westchester County&nbsp;&nbsp;(9)</option>
</select>
    <script type="text/javascript">
        <!--
        var dropdown2 = document.getElementById("cat2");
        function onCatChange2() {
            if ( dropdown2.options[dropdown2.selectedIndex].value > 0 ) {
                location.href = "https://talkofthesound.com/?cat="+dropdown2.options[dropdown2.selectedIndex].value;
            }
        }
        dropdown2.onchange = onCatChange2;
        -->
    </script>
    </div>
    </form>
    
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="navigation-social-bookmarks">
<ul class="social-bookmarks">
<li>
<a href="http://www.facebook.com/talkofthesound/"><i class="fa fa-facebook"></i></a>
</li>
<li>
<a href="http://twitter.com/talkofthesound/"><i class="fa fa-twitter"></i></a>
</li>
	<li>
<a href="http://talkofthesound.com/feed/"><i class="fa fa-rss"></i></a>
</li>
<li><a href="http://YouTube.com/talkofthesound"><i class="fa fa-youtube"></i></a>
</li>
</ul>
</div>
</div></aside>			</div><!-- .widget-area -->
		
	</div><!-- .secondary -->

	</div><!-- .sidebar -->
	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-56659" class="single post-56659 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-new-rochelle">
	
		<div class="post-thumbnail">
			<img width="825" height="510" src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/05/img_7048.jpg?resize=825%2C510&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-lazy-src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/05/img_7048.jpg?resize=825%2C510&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />	</div><!-- .post-thumbnail -->

	

	<header class="entry-header">
		<h1 class="entry-title">Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal</h1>			<div class="the-author">Written By: Robert Cox</div>	</header><!-- .entry-header -->

			<div class="entry-content">
			
<p>NEW ROCHELLE, NY &#8212; The City School District of New Rochelle announced moments ago that Adofo Muhammad has withdrawn as the incoming Principal of New Rochelle High School.</p>


<p>Muhammad issued the following statement:</p>


<blockquote class="wp-block-quote">
  <p>First and foremost, I would like to thank Dr. Feijóo and the New Rochelle Board of Education for an incredible opportunity to come back to my alma mater, New Rochelle High School. As I have said before, it was an opportunity that would be a culmination of my career. I dreamed about walking down the hallways, entering into classes and helping to move the educational and social and emotional vision of New Rochelle to a new plateau. However, unfortunately due to serious family matters which include the death of my grandmother and the compromised health of other loved ones, I will be unable to provide the time and dedication needed to make sure that New Rochelle High School becomes one of the premier high schools in the region.</p>
  <p>It is with great consternation that I must rescind my intentions to become the New Principal of New Rochelle High School. I will forever be indebted to the New Rochelle community for the opportunities that have been afforded to me. My family roots in New Rochelle go back to the late 1800s and I wish the community the best as they move forward.</p>
  <p>Adofo Muhammad</p>
</blockquote>


<p>Superintendent Dr. Laura Feijóo issued the following statement:</p>


<div style="caret-color: rgb(64, 63, 66); color: rgb(64, 63, 66); font-family: Arial, Verdana, Helvetica, sans-serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: left; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-tap-highlight-color: rgba(26, 26, 26, 0.3); -webkit-text-size-adjust: 100%; -webkit-text-stroke-width: 0px; text-decoration: none">
  <blockquote>
    <p><span style="font-size: 14px; font-family: Arial, Verdana, Helvetica, sans-serif; color: rgb(34, 34, 34)">Dear Members of the Community:</span></p>
  </blockquote>
  <blockquote>
    <p><span style="font-size: 14px; font-family: Arial, Verdana, Helvetica, sans-serif; color: rgb(34, 34, 34)">Like so many of you, we were also disappointed to learn of Mr. Muhammad&#8217;s difficult decision to rescind his intention to serve as our next Principal at the high school, which was shared earlier this evening. Positive energy and momentum was already building, and this is a setback. At the same time, we fully support Mr. Muhammad&#8217;s decision. If the current COVID-19 crisis has taught us anything, it is that each of us needs to hold dear and take care of those closest to us.</span></p>
  </blockquote>
</div>
<div style="caret-color: rgb(64, 63, 66); color: rgb(64, 63, 66); font-family: Arial, Verdana, Helvetica, sans-serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: left; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-tap-highlight-color: rgba(26, 26, 26, 0.3); -webkit-text-size-adjust: 100%; -webkit-text-stroke-width: 0px; text-decoration: none">
  <blockquote>
    <p><span style="font-size: 14px; font-family: Arial, Verdana, Helvetica, sans-serif; color: rgb(34, 34, 34)">We recognize that this news undoubtedly raises questions and adds anxieties for a high school community that has already been through so much. Rest assured that we are already hard at work to determine our best options moving forward from this point. In light of the uncertainties already being thrust upon us all by the coronavirus, our extended team has already been actively engaged in creative scenario planning. We look forward to </span>sharing updates as soon as we are able.</p>
  </blockquote>
  <blockquote>
    <p>In the meantime, let&#8217;s all take a big breath and take care of those closest to us. We&#8217;ll move New Rochelle forward together.</p>
  </blockquote>
  <blockquote>
    <p>Sincerely,</p>
  </blockquote>
  <blockquote>
    <p>Dr. Laura Feijóo</p>
  </blockquote>
  <blockquote>
    <p>Superintendent</p>
  </blockquote>
</div>

<p>Muhammad was announced as the high school principal, effective July 1st, at a meeting of the New Rochelle Board of Education on April 14th. He was appointed to fill the position vacated by the 2018 resignation of Reggie Richardson in the wake of the murder of a student and the stabbing on another student 8 days later. Joseph Starvaggi was named interim principal in August 2018. Starvaggi is not eligible to continue for a third year under the “interim” title.</p>


<p>Muhammad came under fire after controversial social media posts came to light minutes after his hiring was announced by the Board. Neither school officials nor Muhammad responded to requests for comment about the social media posts.</p>


<p>While the posts appeared to endorse or associate Adofo Muhammad with The Nation of Islam, Leonard Jeffries, Franklin Jones and other known anti-Semites and make references to what appears to be Islam to the uninitiated, a deeper dive appears to indicate Adofo Muhammad is a “Five Percenter” (and therefore decidedly not Muslim) as some on the school board assumed.</p>


<p>At Tuesday’s school board meeting, Board Vice President Paul Warhit, who is Jewish, engaged in an orchestrated attack on this reporter, most likely dreamed up by Board President Amy Moselhi, who is Muslim, to claim our reporting on Adofo Muhammad’s online persona amounted to Islamophobia.</p>


<p>Warhit is apparently unaware that Five Percenters do not consider Islam a religion and hold positions antithetical to muslim beliefs.</p>


<p>Julia Muggia Ochs, also Jewish, defended Adofo Muhammad against our reporting by citing a 1967 New York Times Op-Ed by author James Baldwin which appears to be an attempt to defend Muhammad’s association with Black Anti-Semites, in part, on the grounds that Jews deserve to be hated by Blacks because Jews are White. This is an odd defense of black anti-Semitism from a Jewish school board member in a District which has had <a href="https://talkofthesound.com/2019/12/13/swastika-and-profanity-found-at-new-rochelle-middle-school-20-and-counting/">20 incidents of Swastikas and Hate Speech directed against Jews at New Rochelle High School, Albert Leonard Middle School and Isaac E. Young Middle School</a> and a tacit admission that the rash of Swastikas in the New Rochelle public schools is not the result of some Smollet-infused fantasy of MAGA-hat wearing skinheads roaming the hallways but far more likely a function of long-simmering resentment of black students against Jewish students.</p>


<div class="wp-block-image">
  <figure class="aligncenter"><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?w=660&#038;ssl=1" alt class="wp-image-56657 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?w=601&amp;ssl=1 601w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?resize=150%2C150&amp;ssl=1 150w" data-lazy-sizes="(max-width: 601px) 100vw, 601px" data-lazy-src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?w=660&#038;ssl=1" alt="" class="wp-image-56657" srcset="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?w=601&amp;ssl=1 601w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/7AE9B652-2927-4613-A38C-8F9D3440E6A1.jpeg?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 601px) 100vw, 601px" data-recalc-dims="1" /></noscript></figure>
</div>


<p><a href="https://archive.nytimes.com/www.nytimes.com/books/98/03/29/specials/baldwin-antisem.html?mcubz=0">Negroes Are Anti-Semitic Because They&#8217;re Anti-White</a></p>


<blockquote class="wp-block-quote">
  <p>In the American context, the most ironical thing about Negro anti-Semitism is that the Negro is really condemning the Jew for having become an American white man&#8211;for having become, in effect, a Christian. The Jew profits from his status in America, and he must expect Negroes to distrust him for it. The Jew does not realize that the credential he offers, the fact that he has been despised and slaughtered, does not increase the Negro&#8217;s understanding. It increases the Negro&#8217;s rage.</p>
</blockquote>


<p>Ultimately, Baldwin concludes that Black Anti-Semitism is driven by Blacks envy of Jews for coming to America and successfully assimilating so as to be considered white Americans by Christians, the real enemy of Black people.</p>


<blockquote class="wp-block-quote">
  <p>The crisis taking place in the world, and in the minds and hearts of black men everywhere, is not produced by the star of David, but by the old, rugged Roman cross on which Christendom&#8217;s most celebrated Jew was murdered. And not by Jews.</p>
</blockquote>


<p>Warhit and Muggia Ochs fail to recognize the strong elements of the Five-Percent ideology that permeates Adofo Muhammad’s online persona. So, what are Five-Percenters?</p>


<p><a href="https://en.m.wikipedia.org/wiki/Five-Percent_Nation">Wikipedia: Five-Percent Nation</a></p>


<blockquote class="wp-block-quote">
  <p>Members of the group call themselves Allah&#8217;s Five Percenters, which reflects the concept that ten percent of the people in the world know the truth of existence, and those elites and their agents opt to keep eighty-five percent of the world in ignorance and under their controlling thumb; the remaining five percent are those who know the truth and are determined to enlighten the eighty-five percent.</p>
</blockquote>


<blockquote class="wp-block-quote">
  <p>The Nation of Gods and Earths teaches that Black people are the original people of the planet Earth, and therefore they are the fathers (&#8220;Gods&#8221;) and mothers (&#8220;Earths&#8221;) of civilization. The Nation teaches that Supreme Mathematics and Supreme Alphabet, a set of principles created by Allah the Father, is the key to understanding humankind&#8217;s relationship to the universe. The Nation does not believe in a god but instead teaches a form of Apotheosis, that the Asiatic Blackman is God and his proper name is &#8220;Allah&#8221;, the Arabic word for &#8220;God&#8221;.</p>
</blockquote>


<p>Five Percenters have culture-specific names for certain cities, including New Rochelle which is known as “Now Rule”.</p>


<blockquote class="wp-block-quote">
  <p>The New York City areas of Harlem (&#8220;Mecca&#8221;) and Brooklyn (&#8220;Medina&#8221;) were named after notable Islamic cities by members of the organization. Other areas include Detroit (&#8220;D-Mecca&#8221;), New Jersey (&#8220;New Jerusalem&#8221;), Chicago (&#8220;C-Medina&#8221;), Queens (&#8220;the Desert&#8221;), Connecticut (&#8220;New Heaven&#8221;), St. Louis (&#8220;Saudi&#8221;), Seattle (&#8220;Morocco&#8221;), New Rochelle (&#8220;Now Rule&#8221;), Dallas (&#8220;Sudan&#8221;), Baltimore (&#8220;Born Mecca&#8221;), Atlanta (&#8220;Allah&#8217;s Garden&#8221;), and Milwaukee (&#8220;Cream City&#8221;).</p>
</blockquote>


<p>Five Percenters are represented within the rap and hip-hop music scene going back to Brand Nubian, an older hip-hop group out of New Rochelle.</p>


<p><a href="https://sites.la.utexas.edu/mhc/files/2009/10/swedenburg_us.pdf">Islam in the Mix: Lessons of the Five Percent</a></p>


<blockquote class="wp-block-quote">
  <p>The Islamic &#8220;sect&#8221;/group to which Brand Nubian belong, known by outsiders as the Five Percent Nation of Islam, by insiders as the Nation of Gods and Earths, hold beliefs so far removed from mainstream Islamic teachings as to be virtually unrecognizable as Islamic to a majority of Muslims. For example, the chant &#8220;allahu akbar&#8221; (&#8220;God is Greatest&#8221;) in the context of this Brand Nubian song means something very different than in mainstream Islamic beliefs. God/Allah, for Five Percenters, is not the Divinity as conventionally defined by the monotheistic faiths. God is the black man. For orthodox Muslims, this is shirk, un-Islamic polytheism.</p>
</blockquote>


<p>None of this addresses the central issue of whether Adofo Muhammad is (was) prepared to run the second largest high school in New York. For many selecting another Black Principal from a tiny, “screened” high school in Brooklyn sounded a lot like the Reggie Richardson version of Groundhog Day.</p>


<p><a href="https://data.nysed.gov/enrollment.php?year=2019&#038;instid=800000057162">New York State Report Card: Bedford Academy High School</a></p>


<p>There is nothing in Adofo Muhammad’s record that would preclude him from being able to succeed at New Rochelle High School but a review of state records shows that Bedford Academy High School where he has been Principal for more than a decade was not remotely similar to what he would have taken on had he not withdrawn.</p>


<p>The best Board President Amy Moselhi and Superintendent Dr. Laura Feijóo could offer beyond platitudes — other than that he graduated from New Rochelle High School in 1988 — is what Moselhi called a “stunning near-perfect graduation rate”.</p>


<div class="wp-block-image">
  <figure class="aligncenter"><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?w=660&#038;ssl=1" alt class="wp-image-56656 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?w=828&amp;ssl=1 828w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?resize=300%2C223&amp;ssl=1 300w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?resize=768%2C571&amp;ssl=1 768w" data-lazy-sizes="(max-width: 660px) 100vw, 660px" data-lazy-src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?w=660&#038;ssl=1" alt="" class="wp-image-56656" srcset="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?w=828&amp;ssl=1 828w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?resize=300%2C223&amp;ssl=1 300w, https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/05/21E7249B-06CB-49FF-9E14-AB4E4D90D7DE.jpeg?resize=768%2C571&amp;ssl=1 768w" sizes="(max-width: 660px) 100vw, 660px" data-recalc-dims="1" /></noscript></figure>
</div>


<p>Is it really stunning that Adofo Muhammad could run a tiny, “screened” school with 361 students subject to academic and personal entrance requirements coupled with a mid-high school career “purge” of 30% of each cohort so that only students he expected to graduate would be allowed to enter their senior year?</p>


<p>According to Inside Schools, Bedford Academy limits who can matriculate into the school, and in the months before senior years culls the rising senior cohort by about 30%.</p>


<p><a href="https://insideschools.org/school/13K595">Inside Schools: Bedford Academy High School</a></p>


<blockquote class="wp-block-quote">
  <p>ADMISSIONS: Screened, with priority to students who live in District 13, and then Brooklyn. Students apply to one of two programs: technology and health professions. They must score at least a 2 on state ELA and math exams (in 2019, 81.4% of students scored a 2 or higher so the school excluded 18.6% of students right off the bat) and have an average of 75 for the technology program and 80 for health professions. Exceptions are made, however, and family commitment to the school&#8217;s rigorous demands is very important, the principal said. Interviews are also considered. In 2017, there were far more applications than seats available. (Isabel Corpus, web reports, May 2018)</p>
</blockquote>


<p>Is it really a 99% graduation rate when half the applicants are denied entry and 30% of those who are admitted do not make it to their senior year? If 200 student apply and 100 students enroll as 9th graders and 30 of those do not make it until Senior year that is more like a 35% graduation rate not 99%.</p>


<p>Bedford Academy High School (BAHS) has just 22 full-time teachers which is smaller than the number of foreign language teachers at New Rochelle High School.</p>


<p>BAHS has a very small number off ELL Students and Students of Disabilities.</p>


<p>New Rochelle High School is more than 50% Hispanic with a large and growing number of ELL students and many students with special needs. Muhammad has little experience dealing with English Language Learners and. Special Education students. BAHS is not diverse, it is over 80% Black.</p>


<p>At Bedford Academy, Muhammad has had the luxury of teaching three classes, including a leadership class for male students, and taking almost the entire month of August off for vacation. Running a school the size of New Rochelle High School is a full-time, 24/7/365 commitment not suited to part-time administrators.</p>


<p>RELATED:</p>
<p><a href="https://talkofthesound.com/2020/04/14/new-rochelle-hires-new-high-school-principal/">New Rochelle Hires New High School Principal</a></p>
<p><a href="https://talkofthesound.com/2020/04/16/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-nation-of-islam/"><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/04/044DC888-40F8-4B37-85FE-92A7A19AC12B.jpeg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/04/044DC888-40F8-4B37-85FE-92A7A19AC12B.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/04/044DC888-40F8-4B37-85FE-92A7A19AC12B.jpeg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></a></p>
<p><a href="https://talkofthesound.com/2020/04/16/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-nation-of-islam/">What’s the Deal with Newly Hired New Rochelle High School Principal and the Nation of Islam?</a></p>
<p><a href="https://talkofthesound.com/2020/04/16/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-nation-of-islam/"><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/img_7069.jpg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/img_7069.jpg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/img_7069.jpg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></a></p>
<p><a href="https://talkofthesound.com/2020/04/29/message-from-adofo-muhammad-2/">Message from Adofo Muhammad</a></p>
<p><a href="https://talkofthesound.com/2020/04/29/message-from-adofo-muhammad-2/"><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/aHR0cHM6Ly9maWxlcy5jb25zdGFudGNvbnRhY3QuY29tL2RlZDFlOGEzNTAxL2RjZGIxNDg5LTAzM2UtNDIyOC1iYjZlLWUyOGM1Y2M1NWMwNC5qcGc.jpeg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/aHR0cHM6Ly9maWxlcy5jb25zdGFudGNvbnRhY3QuY29tL2RlZDFlOGEzNTAxL2RjZGIxNDg5LTAzM2UtNDIyOC1iYjZlLWUyOGM1Y2M1NWMwNC5qcGc.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/talkofthesound.com/wp-content/uploads/2020/04/aHR0cHM6Ly9maWxlcy5jb25zdGFudGNvbnRhY3QuY29tL2RlZDFlOGEzNTAxL2RjZGIxNDg5LTAzM2UtNDIyOC1iYjZlLWUyOGM1Y2M1NWMwNC5qcGc.jpeg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></a></p>
<p><a href="https://talkofthesound.com/2020/04/29/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-black-people-matrix/">What’s the Deal with the Newly Hired New Rochelle High School Principal and the Black People Matrix</a></p>
<p><a href="https://talkofthesound.com/2020/04/29/whats-the-deal-with-newly-hired-the-new-rochelle-high-school-principal-and-the-black-people-matrix/"><img src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/04/JonesImage.jpg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/04/JonesImage.jpg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/04/JonesImage.jpg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></a></p>
<p><a href="https://talkofthesound.com/2020/05/05/whats-the-deal-with-the-newly-hired-new-rochelle-high-school-principal-and-r-kelly/">What’s the Deal with the Newly Hired New Rochelle High School Principal and R. Kelly?</a></p>
<p><a href="https://talkofthesound.com/2020/05/07/whats-the-deal-with-the-newly-hired-new-rochelle-high-school-principal-kanye-west-and-kim-kardashian/"><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/05/2765F8CC-45BD-452A-989B-9A539DAD941B.jpeg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/05/2765F8CC-45BD-452A-989B-9A539DAD941B.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/talkofthesound.com/wp-content/uploads/2020/05/2765F8CC-45BD-452A-989B-9A539DAD941B.jpeg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></a></p>
<p><a href="https://talkofthesound.com/2020/05/07/whats-the-deal-with-the-newly-hired-new-rochelle-high-school-principal-kanye-west-and-kim-kardashian/"></a></p>
<p><a href="https://talkofthesound.com/2020/05/07/whats-the-deal-with-the-newly-hired-new-rochelle-high-school-principal-kanye-west-and-kim-kardashian/">What’s the Deal with the Newly Hired New Rochelle High School Principal, Kanye West and Kim Kardashian</a></p>
<p><img src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/05/B43ECDF7-064E-4A5A-A15F-6388B117CDC1.jpeg?w=660&#038;ssl=1" class="size-full jetpack-lazy-image" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/05/B43ECDF7-064E-4A5A-A15F-6388B117CDC1.jpeg?w=660&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/talkofthesound.com/wp-content/uploads/2020/05/B43ECDF7-064E-4A5A-A15F-6388B117CDC1.jpeg?w=660&#038;ssl=1" class="size-full" data-recalc-dims="1"></noscript></p><div id="ess-main-wrapper">
	<div id="ess-wrap-inline-networks" class="ess-inline-networks-container ess-clear ess-inline-bottom ess-diagonal-icon ess-inline-layout-one">
		<ul class="ess-social-network-lists">
							<li class="ess-social-networks ess-facebook ess-spacing ess-social-sharing">
					<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;t=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="facebook" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-facebook" data-tip="Facebook"></span>
													<span class="ess-text">Facebook</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-twitter ess-spacing ess-social-sharing">
					<a href="http://twitter.com/share?text=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;via=talkofthesound" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="twitter" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-twitter" data-tip="Twitter"></span>
													<span class="ess-text">Twitter</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-linkedin ess-spacing ess-social-sharing">
					<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="linkedin" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-linkedin" data-tip="Linkedin"></span>
													<span class="ess-text">LinkedIn</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-googleplus ess-spacing ess-social-sharing">
					<a href="https://plus.google.com/share?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;t=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="googleplus" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-googleplus" data-tip="Googleplus"></span>
													<span class="ess-text">Google+</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-stumbleupon ess-spacing ess-social-sharing">
					<a href="http://www.stumbleupon.com/badge?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-network-link ess-social-share ess-display-counts" rel="nofollow" data-social-name="stumbleupon" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-stumbleupon" data-tip="Stumbleupon"></span>
													<span class="ess-text">StumbleUpon</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
							<li class="ess-social-networks ess-pinterest ess-spacing ess-social-sharing">
					<a href="#" class="ess-social-network-link ess-social-share-pinterest ess-display-counts" rel="nofollow" data-social-name="pinterest" data-min-count="0" data-post-id="56659" data-location="inline">
						<span class="inline-networks socicon ess-icon socicon-pinterest" data-tip="Pinterest"></span>
													<span class="ess-text">Pinterest</span>
																			<span class="ess-social-count"></span>
											</a>
				</li>
										<li class="ess-all-networks ess-social-networks">
					<div class="ess-social-network-link">
						<span class="ess-all-networks-button"><i aria-hidden="true" class="fa fa-ellipsis-h"></i></span>
					</div>
				</li>
										<li class="ess-total-share ess-social-networks" data-post-id="56659"><div class="ess-total-share-block"><i class="fa fa-share-alt"></i> <span class="ess-total-count"></span><span class="ess-share-text">Shares</span></div></li>
					</ul>
	</div>
</div>
		</div><!-- .entry-content -->
		
		<footer class="entry-footer">
			<span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/" rel="bookmark"><time class="entry-date published" datetime="2020-05-07T18:43:19-04:00">May 7, 2020</time><time class="updated" datetime="2020-05-08T01:16:42-04:00">May 8, 2020</time></a></span><span class="byline"><span class="author vcard"><span class="screen-reader-text">Author </span><a class="url fn n" href="https://talkofthesound.com/author/robert-cox/">Robert Cox</a></span></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://talkofthesound.com/category/front-page/education/" rel="category tag">Education</a>, <a href="https://talkofthesound.com/category/front-page/new-rochelle/" rel="category tag">New Rochelle</a></span>					</footer><!-- .entry-footer -->
	
</article><!-- #post-## -->

<div id="comments" class="comments-area">

			<h2 class="comments-title">
			4 thoughts on &ldquo;Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal&rdquo;		</h2>

		
		<ol class="comment-list">
					<li id="comment-25703" class="comment even thread-even depth-1 parent">
			<article id="div-comment-25703" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/de207eb8639e417066dca978f04856b5?s=56&#038;r=pg" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" data-lazy-srcset="https://secure.gravatar.com/avatar/de207eb8639e417066dca978f04856b5?s=112&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/de207eb8639e417066dca978f04856b5?s=56&amp;is-pending-load=1#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/de207eb8639e417066dca978f04856b5?s=56&#038;r=pg' srcset='https://secure.gravatar.com/avatar/de207eb8639e417066dca978f04856b5?s=112&#038;r=pg 2x' class='avatar avatar-56 photo' height='56' width='56' /></noscript>						<b class="fn">Alan striar</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/#comment-25703">
							<time datetime="2020-05-07T22:21:29-04:00">
								May 7, 2020 at 10:21 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>If your analysis is correct how is it possible that our school system has fallen to this level. 48 years in this community children and grand children graduating , tonight I am very sad.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/?replytocom=25703#respond' data-commentid="25703" data-postid="56659" data-belowelement="div-comment-25703" data-respondelement="respond" aria-label='Reply to Alan striar'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-25706" class="comment byuser comment-author-robert-cox bypostauthor odd alt depth-2">
			<article id="div-comment-25706" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&#038;r=pg" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" data-lazy-srcset="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=112&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&amp;is-pending-load=1#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&#038;r=pg' srcset='https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=112&#038;r=pg 2x' class='avatar avatar-56 photo' height='56' width='56' /></noscript>						<b class="fn">Robert Cox</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/#comment-25706">
							<time datetime="2020-05-07T23:53:54-04:00">
								May 7, 2020 at 11:53 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Analysis? My reporting is accurate.<br />
I am not clear on what precisely you are commenting upon but our school district changed on January 10, 2018.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/?replytocom=25706#respond' data-commentid="25706" data-postid="56659" data-belowelement="div-comment-25706" data-respondelement="respond" aria-label='Reply to Robert Cox'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-25702" class="comment even thread-odd thread-alt depth-1 parent">
			<article id="div-comment-25702" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/351ca42cfb237f88069b61b840ea5add?s=56&#038;r=pg" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" data-lazy-srcset="https://secure.gravatar.com/avatar/351ca42cfb237f88069b61b840ea5add?s=112&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/351ca42cfb237f88069b61b840ea5add?s=56&amp;is-pending-load=1#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/351ca42cfb237f88069b61b840ea5add?s=56&#038;r=pg' srcset='https://secure.gravatar.com/avatar/351ca42cfb237f88069b61b840ea5add?s=112&#038;r=pg 2x' class='avatar avatar-56 photo' height='56' width='56' /></noscript>						<b class="fn">Chance Kelly</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/#comment-25702">
							<time datetime="2020-05-07T21:08:10-04:00">
								May 7, 2020 at 9:08 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Thank you Bob.</p>
<p>It is as ponderous as it is depressing.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/?replytocom=25702#respond' data-commentid="25702" data-postid="56659" data-belowelement="div-comment-25702" data-respondelement="respond" aria-label='Reply to Chance Kelly'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-25704" class="comment byuser comment-author-robert-cox bypostauthor odd alt depth-2">
			<article id="div-comment-25704" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&#038;r=pg" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" data-lazy-srcset="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=112&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&amp;is-pending-load=1#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=56&#038;r=pg' srcset='https://secure.gravatar.com/avatar/177006f511c5c0c45c749c1154b83ffa?s=112&#038;r=pg 2x' class='avatar avatar-56 photo' height='56' width='56' /></noscript>						<b class="fn">Robert Cox</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/#comment-25704">
							<time datetime="2020-05-07T23:44:48-04:00">
								May 7, 2020 at 11:44 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>You are welcome</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/?replytocom=25704#respond' data-commentid="25704" data-postid="56659" data-belowelement="div-comment-25704" data-respondelement="respond" aria-label='Reply to Robert Cox'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&#038;postid=56659&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=3ad645cfb16011cf5feb20b74ce13907f9be4bd4#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.tapinto.net/towns/paterson/articles/investigation-leads-to-4-arrests-almost-3-500-glassines-of-heroin-loaded-gun" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">New Rochelle Man in New Jersey Heroin Bust</span></a></div><div class="nav-next"><a href="http://www.news12.com/clip/15061508/connecticut-man-does-double-duty-as-teacher-and-respiratory-therapist-in-westchester" rel="next"><span class="meta-nav" aria-hidden="true">Next</span> <span class="screen-reader-text">Next post:</span> <span class="post-title">Connecticut man does double duty as teacher and respiratory therapy</span></a></div></div>
	</nav>
		</main><!-- .site-main -->
	</div><!-- .content-area -->


</div><!-- .site-content -->

<footer id="colophon" class="site-footer" role="contentinfo">
    <div class="site-info">
        		<a href="/about" title="About Talk of the Sound">About</a> | <a href="/contact" title="Contact Talk of the Sound">Contact</a> | <a href="/terms-of-service/" title="Terms of Service">Terms of Service</a> | © 2008-2019 Talk of the Sound. All rights reserved.
		    </div><!-- .site-info -->
</footer><!-- .site-footer -->

</div><!-- .site -->

<div id="ess-main-wrapper">
	<div class="ess-popup-overlay"></div>
	<div class="ess-pinterest-popup-overlay"></div>
	<div class="ess-popup-wrapper">
		<div class="ess-popup-close"><i class="fa fa-close"></i></div>
		<div id="ess-wrap-inline-networks">
			<ul class="ess-social-network-lists">
									<li class="ess-social-networks ess-facebook ess-spacing ess-social-sharing">
						<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;t=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-facebook"></span>
							<span class="ess-text">Facebook</span>
						</a>
					</li>
									<li class="ess-social-networks ess-twitter ess-spacing ess-social-sharing">
						<a href="http://twitter.com/share?text=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;via=talkofthesound" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-twitter"></span>
							<span class="ess-text">Twitter</span>
						</a>
					</li>
									<li class="ess-social-networks ess-googleplus ess-spacing ess-social-sharing">
						<a href="https://plus.google.com/share?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;t=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-googleplus"></span>
							<span class="ess-text">Google+</span>
						</a>
					</li>
									<li class="ess-social-networks ess-linkedin ess-spacing ess-social-sharing">
						<a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-linkedin"></span>
							<span class="ess-text">LinkedIn</span>
						</a>
					</li>
									<li class="ess-social-networks ess-pinterest ess-spacing ess-social-sharing">
						<a href="#" class="ess-social-share-pinterest" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-pinterest"></span>
							<span class="ess-text">Pinterest</span>
						</a>
					</li>
									<li class="ess-social-networks ess-stumbleupon ess-spacing ess-social-sharing">
						<a href="http://www.stumbleupon.com/badge?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-stumbleupon"></span>
							<span class="ess-text">StumbleUpon</span>
						</a>
					</li>
									<li class="ess-social-networks ess-tumblr ess-spacing ess-social-sharing">
						<a href="https://www.tumblr.com/share?v=3&#038;u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;t=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-tumblr"></span>
							<span class="ess-text">Tumblr</span>
						</a>
					</li>
									<li class="ess-social-networks ess-blogger ess-spacing ess-social-sharing">
						<a href="https://www.blogger.com/blog_this.pyra?t&#038;u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;n=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-blogger"></span>
							<span class="ess-text">Blogger</span>
						</a>
					</li>
									<li class="ess-social-networks ess-myspace ess-spacing ess-social-sharing">
						<a href="https://myspace.com/post?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-myspace"></span>
							<span class="ess-text">Myspace</span>
						</a>
					</li>
									<li class="ess-social-networks ess-delicious ess-spacing ess-social-sharing">
						<a href="https://delicious.com/post?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-delicious"></span>
							<span class="ess-text">Delicious</span>
						</a>
					</li>
									<li class="ess-social-networks ess-yahoomail ess-spacing ess-social-sharing">
						<a href="http://compose.mail.yahoo.com/?body=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-yahoomail"></span>
							<span class="ess-text">Yahoo Mail</span>
						</a>
					</li>
									<li class="ess-social-networks ess-gmail ess-spacing ess-social-sharing">
						<a href="https://mail.google.com/mail/u/0/?view=cm&#038;fs=1&#038;su=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal&#038;body=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;ui=2&#038;tf=1" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-gmail"></span>
							<span class="ess-text">Gmail</span>
						</a>
					</li>
									<li class="ess-social-networks ess-newsvine ess-spacing ess-social-sharing">
						<a href="http://www.newsvine.com/_tools/seed&#038;save?u=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;h=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-newsvine"></span>
							<span class="ess-text">Newsvine</span>
						</a>
					</li>
									<li class="ess-social-networks ess-digg ess-spacing ess-social-sharing">
						<a href="http://digg.com/submit?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-digg"></span>
							<span class="ess-text">Digg</span>
						</a>
					</li>
									<li class="ess-social-networks ess-friendfeed ess-spacing ess-social-sharing">
						<a href="http://friendfeed.com/?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-friendfeed"></span>
							<span class="ess-text">FriendFeed</span>
						</a>
					</li>
									<li class="ess-social-networks ess-buffer ess-spacing ess-social-sharing">
						<a href="https://bufferapp.com/add?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-buffer"></span>
							<span class="ess-text">Buffer</span>
						</a>
					</li>
									<li class="ess-social-networks ess-reddit ess-spacing ess-social-sharing">
						<a href="http://www.reddit.com/submit?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F&#038;title=Adofo%20Muhammad%20Withdraws%20as%20Incoming%20New%20Rochelle%20High%20School%20Principal" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-reddit"></span>
							<span class="ess-text">Reddit</span>
						</a>
					</li>
									<li class="ess-social-networks ess-vkontakte ess-spacing ess-social-sharing">
						<a href="http://vk.com/share.php?url=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F" class="ess-social-share" rel="nofollow" data-location="modal">
							<span class="inline-networks socicon ess-icon socicon-vkontakte"></span>
							<span class="ess-text">VKontakte</span>
						</a>
					</li>
							</ul>
		</div>
	</div>
</div>
<div id="ess-main-wrapper">
	<div class="ess-pinterest-img-picker-popup">
		<h3 class="ess-pinterest-popup-title">Pin It on Pinterest</h3>
		<div class="ess-pinterest-popup-close"><i class="fa fa-close"></i></div>
		<div class="ess-social-pin-images" data-permalink="https://talkofthesound.com/2020/05/07/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal/" data-title="Adofo Muhammad Withdraws as Incoming New Rochelle High School Principal" data-post_id="56659"></div>
		<div class="ess-no-pinterest-img-found"></div>
	</div>
</div>
        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        <script src='https://c0.wp.com/p/jetpack/8.5/_inc/build/photon/photon.min.js'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/jquery-tiptip/jquery.tipTip.min.js?ver=3.5.4'></script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/jquery-idletimer/idle-timer.min.js?ver=1.1.0'></script>
<script>
var easy_social_sharing_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","page_url":"https:\/\/talkofthesound.com\/2020\/05\/07\/adofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal\/","update_share_nonce":"a4552b017f","shares_count_nonce":"cc98650394","all_network_shares_count_nonce":"29ef4175be","total_counts_nonce":"8a9ea09b7e","i18n_no_img_message":"No images found.","network_data":{"facebook":{"network_id":"1","network_name":"facebook","network_desc":"Facebook","network_order":"1","network_count":"0","is_api_support":"1"},"twitter":{"network_id":"2","network_name":"twitter","network_desc":"Twitter","network_order":"2","network_count":"0","is_api_support":"0"},"linkedin":{"network_id":"3","network_name":"linkedin","network_desc":"Linkedin","network_order":"3","network_count":"0","is_api_support":"1"},"googleplus":{"network_id":"4","network_name":"googleplus","network_desc":"Googleplus","network_order":"4","network_count":"0","is_api_support":"1"},"stumbleupon":{"network_id":"5","network_name":"stumbleupon","network_desc":"Stumbleupon","network_order":"5","network_count":"0","is_api_support":"1"},"pinterest":{"network_id":"6","network_name":"pinterest","network_desc":"Pinterest","network_order":"6","network_count":"0","is_api_support":"1"}}};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/plugins/easy-social-sharing/assets/js/frontend/easy-social-sharing.min.js?ver=1.3.2'></script>
<script src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/skip-link-focus-fix.js?ver=20141028'></script>
<script src='https://c0.wp.com/c/5.4.1/wp-includes/js/comment-reply.min.js'></script>
<script>
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
</script>
<script src='https://4a0izvbtoyv1k7lcd14x3s61-wpengine.netdna-ssl.com/wp-content/themes/twentyfifteen/js/functions.js?ver=20171218'></script>
<script src='https://c0.wp.com/p/jetpack/8.5/_inc/build/lazy-images/js/lazy-images.min.js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&postid=56659&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3ad645cfb16011cf5feb20b74ce13907f9be4bd4#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=175374175&postid=56659&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=3ad645cfb16011cf5feb20b74ce13907f9be4bd4#parent=https%3A%2F%2Ftalkofthesound.com%2F2020%2F05%2F07%2Fadofo-muhammad-withdraws-as-incoming-new-rochelle-high-school-principal%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202019.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'175374175',post:'56659',tz:'-4',srv:'talkofthesound.com'} ]);
	_stq.push([ 'clickTrackerInit', '175374175', '56659' ]);
</script>
<script>
    var these = document.getElementById('secondary').getElementsByClassName('widget-title');
    if (these.length) {
        for (var n = 0, m = these.length; n < m; n++) {
            var thisWidghet = these[n];
            if (thisWidghet.tagName == "H2") {
                thisWidghet.addEventListener('click', function () {
                    var thisParent = this.parentNode;
                    if (thisParent.tagName == "ASIDE") {
                        toggle_visibility(thisParent);
                    }
                }, false);
            }
        }
    }
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
//	(adsbygoogle = window.adsbygoogle || []).push({
//		google_ad_client: "ca-pub-5602862681328597",
//		enable_page_level_ads: true
//	});
</script>
</body>
</html>
